The technical team has implemented a temporary workaround to bypass the issues caused by our supplier. The website is now operational, although users may experience slower performance than usual.
We are continuing to work with our supplier towards a permanent resolution and will provide further updates as they become available.
Posted Jul 16, 2026 - 10:09 UTC
Identified
The issue has been identified, and we are working with our hosting providers to resolve the matter. We will provide further updates as more information becomes available.
Posted Jul 16, 2026 - 10:01 UTC
Update
We are continuing to investigate this issue.
Posted Jul 16, 2026 - 09:37 UTC
Investigating
We have received reports that some clients are unable to access storfund.com. We are currently investigating the issue and will provide updates as soon as more information becomes available.